Page 1 of 2 12 LastLast
Results 1 to 20 of 26

Thread: 90hp Yamaha 4skroke

  1. #1
    Join Date
    Sep 2004
    Location
    Camdenshire
    Posts
    6,648

    Default 90hp Yamaha 4skroke

    New thermostat, new water pump assembly, pop valve is clear. Motor will not pee in neutral or idle speed. What's goin on.
    Quote Originally Posted by walt4dun View Post
    Monsters... Be damned if I'd ever be taken alive by the likes of faggot musslims.
    Quote Originally Posted by 2thDoc View Post
    I am an equal opportunity hater.

  2. #2
    Join Date
    Nov 2012
    Location
    Pawleys Island
    Posts
    899

    Default

    Original impeller?
    "some men are mere hunters, others are turkey hunters"-Archibald Rutledge

  3. #3
    Join Date
    Sep 2004
    Location
    Camdenshire
    Posts
    6,648

    Default

    No.
    Quote Originally Posted by walt4dun View Post
    Monsters... Be damned if I'd ever be taken alive by the likes of faggot musslims.
    Quote Originally Posted by 2thDoc View Post
    I am an equal opportunity hater.

  4. #4
    Join Date
    Dec 2007
    Location
    Providence
    Posts
    3,750

    Default

    Did you replace the housing or just the impeller? Housing might be worn.

  5. #5
    Join Date
    Aug 2011
    Location
    Charleston
    Posts
    1,500

    Default

    Did you reconnect the hose when putting the lower unit back on? Are all the water hoses obstruction free? Are you running it long enough for it to heat up and pop open to start flowing?

  6. #6
    Join Date
    Jan 2009
    Location
    Murrells Inlet
    Posts
    1,290

    Default

    To verify, telltale flow at higher RPM?

    Any alarm? Checked the telltale for obstruction, ie sand grain, grass, stick?

    Have had sand block at lower RPM and shoot a stream at higher RPM with more force around it.

  7. #7
    Join Date
    Jan 2005
    Location
    FROG LEVEL
    Posts
    17,859

    Default

    Check for dirtdabbers in your lines. They clogged mine up before
    Gettin old is for pussies! AND MY NEW TRUE people say like Capt. Tom >>>>>>>>>/
    "Wow, often imitated but never duplicated. No one can do it like the master. My hat is off to you DRDUCK!"

  8. #8
    Join Date
    Sep 2004
    Location
    Camdenshire
    Posts
    6,648

    Default

    Telltale is clean. Lower housing is new. Upper is in fine condition. It will pee at 1/4 throttle. No alarms. It just bothers me that it won't pee at neutral and idol.
    Quote Originally Posted by walt4dun View Post
    Monsters... Be damned if I'd ever be taken alive by the likes of faggot musslims.
    Quote Originally Posted by 2thDoc View Post
    I am an equal opportunity hater.

  9. #9
    Join Date
    Jan 2009
    Location
    In a house
    Posts
    7,586

    Default

    Make sure the keyway is in with the impeller
    "I'm just a victim of a circumstance"

  10. #10
    Join Date
    Jan 2005
    Location
    FROG LEVEL
    Posts
    17,859

    Default

    Quote Originally Posted by willk View Post
    Telltale is clean. Lower housing is new. Upper is in fine condition. It will pee at 1/4 throttle. No alarms. It just bothers me that it won't pee at neutral and idol.
    It would bother me to. Something ain't right
    Gettin old is for pussies! AND MY NEW TRUE people say like Capt. Tom >>>>>>>>>/
    "Wow, often imitated but never duplicated. No one can do it like the master. My hat is off to you DRDUCK!"

  11. #11
    Join Date
    Dec 2010
    Location
    Summerville
    Posts
    11,684

    Default

    Are you doing this on a flush or backed into the water?

  12. #12
    Join Date
    Dec 2010
    Posts
    18,603

    Default

    Is it running hot?
    New thermostat may be not opening up, or in upside down. Take it out and drop it in a pan of boiling water on the stove and see if it opens
    or low water pressure. Turn water hose up for stronger water flow
    Last edited by ecu1984; 08-02-2019 at 02:14 PM.
    Meet Dick, Dick is a Climp5in fan.....Don't be a Dick

  13. #13
    Join Date
    Sep 2004
    Location
    spartanburg
    Posts
    2,815

    Default

    I had a broken impeller blade stuck in the water passage before.
    Low country redneck who moved north

  14. #14
    Join Date
    Sep 2004
    Location
    Camdenshire
    Posts
    6,648

    Default

    Thermostat is in correct. We tested it with shop water but it was only 140 degrees. Also. Other that it was acting this way before new parts were installed.
    Quote Originally Posted by walt4dun View Post
    Monsters... Be damned if I'd ever be taken alive by the likes of faggot musslims.
    Quote Originally Posted by 2thDoc View Post
    I am an equal opportunity hater.

  15. #15
    Join Date
    Sep 2004
    Location
    Camdenshire
    Posts
    6,648

    Default

    The keyway is in the impeller.
    Quote Originally Posted by walt4dun View Post
    Monsters... Be damned if I'd ever be taken alive by the likes of faggot musslims.
    Quote Originally Posted by 2thDoc View Post
    I am an equal opportunity hater.

  16. #16
    Join Date
    Sep 2004
    Location
    spartanburg
    Posts
    2,815

    Default

    Have all impeller blades been accounted for in the past? Weed eater line makes a good passage chase.
    Low country redneck who moved north

  17. #17
    Join Date
    Nov 2011
    Location
    Jame isle
    Posts
    5,241

    Default

    Impeller in upside down
    867-5309

  18. #18
    Join Date
    Nov 2011
    Location
    Jame isle
    Posts
    5,241

    Default

    Excuse me the blades are in reverse
    867-5309

  19. #19
    Join Date
    Oct 2007
    Location
    columbia
    Posts
    573

    Default

    Could be this

  20. #20
    Join Date
    Aug 2004
    Location
    Hopkins
    Posts
    509

    Default

    Does that model have a fuel cooler? Some of the four stroke yamas do. It is just a vertical loop in the cooling system that has a u-shape tube at the top of it that is easy to clog.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •